Failed to start Web Service

SPC Web Gateway support issues
Vinceefr
Posts: 2
Joined: Thu 05 Mar 2015, 22:16

Failed to start Web Service

Post by Vinceefr » Wed 08 Jun 2016, 22:07

Hi,
I finally took time after several months to install the SPC-WEB-GATEWAY.
Unfortunately I get the following error when starting the gateway on my raspberry:

License valid until 2038-01-01
Waiting for PANEL...
Connection established
spc-web-gateway: Failed to start Web Service

Could you please help ?
I have a phpmysql running on my Raspberry on Apache, could it be linked to this ?

Regards,
Vincent

gol
Webbplatsadministratör
Posts: 81
Joined: Sun 01 Jun 2014, 19:38

Re: Failed to start Web Service

Post by gol » Thu 09 Jun 2016, 16:03

Probably you already have another instance of spc-web-gateway running or the configured port (default 8088) is already used by another process.

izzor
Posts: 1
Joined: Tue 13 Sep 2016, 07:16

Re: Failed to start Web Service

Post by izzor » Thu 15 Sep 2016, 10:02

I have the same problem on a new installation of Ubuntu 16.04.
The gateway starts and waits for the panel and when the panel connects I get the message
spc-web-gateway: Failed to start Web Service

The application runs fine on an old Ubuntu 14.04 server.

Vincents and my problems might be related.

Regards,
Pekka

efesler
Posts: 2
Joined: Sat 25 Nov 2017, 19:59

Re: Failed to start Web Service

Post by efesler » Sat 25 Nov 2017, 20:22

Hello,

I just installed sac-web-gateway on a new raspberry pi 3 (with raspbian jessie) and I got the following message when I try to start spa-web-gateway:

License valid until 2038-01-01
Waiting for PANEL...
Connection established
spc-web-gateway: Failed to start Web Service

spa-web-gateway version is : rp 1.2

No other service is running on port 8088.

Any idea of what could be wrong ?

Regards,

Eric

gol
Webbplatsadministratör
Posts: 81
Joined: Sun 01 Jun 2014, 19:38

Re: Failed to start Web Service

Post by gol » Sat 25 Nov 2017, 20:37

Hi Eric,
Are you sure you have not missed to install the required packages openssl and libssl-dev according to the Installation Guide section 2.1 Installation Prerequisites.

//Goran

efesler
Posts: 2
Joined: Sat 25 Nov 2017, 19:59

Re: Failed to start Web Service

Post by efesler » Sat 25 Nov 2017, 21:08

Hello Goran,

that was it.

Sorry, I pass through this point.

Thanks for the quick reply.

Regards,

//Eric

roryd
Posts: 10
Joined: Tue 21 Jun 2016, 16:05

Re: Failed to start Web Service

Post by roryd » Wed 09 May 2018, 13:50

Hi,

I upgraded from Ubuntu 17.10 to 18.04, and I now have issues.

The SPC Web Gateway will only start if I disable SSL Authentication in config.xml. If SSL Authentication is set to "yes", I get this:

rory@openhab:/opt/spc-web-gateway$ ./spc-web-gateway -d
License valid until 2030-01-01
Waiting for PANEL...
Connection established
spc-web-gateway: Failed to start Web Service
rory@openhab:/opt/spc-web-gateway$

Also, node-spc-mqtt won't work, but I assume that's because SSL Authentication is now not working in the web gateway.

openssl and libssl-dev are both installed.

Is there any other logging done anywhere? (I found /var/log/spc-web-gateway.log but it's empty).

Any ideas?

gol
Webbplatsadministratör
Posts: 81
Joined: Sun 01 Jun 2014, 19:38

Re: Failed to start Web Service

Post by gol » Wed 09 May 2018, 14:53

Hi Rory,
Which version of SPC Web Gateway do you have?
//Goran

roryd
Posts: 10
Joined: Tue 21 Jun 2016, 16:05

Re: Failed to start Web Service

Post by roryd » Wed 09 May 2018, 15:26

Hi Goran,

It's version ubuntu_x86_64.1.2

Rory.

gol
Webbplatsadministratör
Posts: 81
Joined: Sun 01 Jun 2014, 19:38

Re: Failed to start Web Service

Post by gol » Wed 09 May 2018, 15:35

Please try latest version 1.3 that I have sent to you.
//Goran

Post Reply